Magnus Health Community Access Issues
Incident Report for Magnus Health
Resolved
The issue with the Magnus Health Community has been resolved and users should once again be able to sign in. We apologize for any inconvenience.
Posted Oct 12, 2023 - 13:57 EDT
Investigating
We are investigating an issue preventing users from signing into the Magnus Health Community. While we investigate further, please visit https://community.magnushealth.com/s/ directly to search our knowledge base and email clientservices@magnushealthportal.com to submit new support requests.
Posted Oct 12, 2023 - 11:46 EDT
This incident affected: Magnus Community.