Fax Systems Down Due to Third Party Outage
Incident Report for Magnus Health
Resolved
The issue impacting our fax systems has been resolved and we can once again accept incoming customer faxes. Thank you for your patience while we worked to resolve this issue.
Posted Jul 19, 2024 - 10:31 EDT
Investigating
Due to a third-party outage impacting global tech platforms our fax systems are currently unable to accept incoming customer faxes. We are working to resolve the issue as quickly as possible, but in the interim please upload files directly from our mobile or desktop applications.
Posted Jul 19, 2024 - 08:38 EDT
This incident affected: Services (Incoming Fax Services).