Issue with Closing Cases in the MH Community
Incident Report for Magnus Health
Resolved
We have identified and resolved the issue that was preventing customers from closing support cases within the Community.
Posted Mar 26, 2024 - 10:07 EDT
Investigating
We are currently investigating an issue preventing customers from closing support cases within the Magnus Health Community. We appreciate your patience and will provide an update as soon as we are able.
Posted Mar 26, 2024 - 09:51 EDT
This incident affected: Magnus Community.